Tuesday, 23 April 2013

New Mandatory Update To Thexyz Cloud Backup Agent


On Monday 29th April we will be setting the minimum required version of the Thexyz client to 1.12.6. All previous versions of the client will no longer be supported by Thexyz and will stop connecting to the cloud. This means that if you are running an older version of the Windows and Mac client software your back-ups will no longer run and no data will be synced via the briefcase. Any existing data stored in your cloud account will remain in the cloud and will still be accessible through the web portal and mobile apps.

Thexyz Now Supports Windows 8


Version 1.12.6 of our Desktop software for Windows and Mac includes an improved status screen, bandwidth settings, and many stability improvements. The Windows version of the software also now fully supports Windows 8.

Customers who have a previous version of the client software already installed will see a pop up notification on their desktop asking them to upgrade.

If you have any questions, please contact the support team: https://www.thexyz.com/support.html

Trending Posts

Blog Archive

Subscribe by email

Enter your email address:

Subscribe to more feeds

Tags

News (73) Web Hosting (48) Email (28) security (22) Advertising (17) webmail (17) Tutorials (16) Thexyz Cloud (14) Video (5) resellers (2)